summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/mkelfimage/mkelfimage_git.bb')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
deleted file mode 100644
index 330fa7c9a7..0000000000
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1SUMMARY = "Utility for creating ELF boot images for ELF-based Linux kernel images"
2HOMEPAGE = "http://www.coreboot.org/Mkelfimage"
3SECTION = "devel"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a"
6
7SRCREV = "686a48a339b3200184c27e7f98d4c03180b2be6c"
8PV = "4.0+git${SRCPV}"
9RECIPE_NO_UPDATE_REASON = "mkelfimage has been removed in coreboot 4.1 release: \
10http://review.coreboot.org/gitweb?p=coreboot.git;a=commit;h=34fc4ab80b507739e2580d490dff67fcfdde11ea"
11
12
13DEPENDS += "zlib"
14
15SRC_URI = "git://review.coreboot.org/p/coreboot;protocol=http \
16 file://cross-compile.patch \
17 "
18SRC_URI_append_class-native = " \
19 file://fix-makefile-to-find-libz.patch \
20 file://convert.bin.c \
21"
22
23CLEANBROKEN = "1"
24
25S = "${WORKDIR}/git/util/mkelfImage"
26
27CACHED_CONFIGUREVARS += "\
28 HOST_CC='${BUILD_CC}' \
29 HOST_CFLAGS='${BUILD_CFLAGS}' \
30 HOST_CPPFLAGS='${BUILD_CPPFLAGS}' \
31 I386_CFLAGS='-fno-stack-protector' \
32 IA64_CFLAGS='-fno-stack-protector' \
33"
34EXTRA_OECONF_append_x86-64 = " --with-i386=${HOST_SYS}"
35
36inherit autotools-brokensep
37
38do_configure_prepend-class-native() {
39 cp ${WORKDIR}/convert.bin.c ${S}/linux-i386/
40}
41
42do_install_append() {
43 rmdir ${D}${datadir}/mkelfImage/elf32-i386
44 rmdir ${D}${datadir}/mkelfImage
45 chown root:root ${D}/${sbindir}/mkelfImage
46}
47
48BBCLASSEXTEND = "native"