summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 1f47e5d0fb..2d346b70cf 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -8,7 +8,7 @@ SECTION = "devel"
8 8
9LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe" 9LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe"
10 10
11DEPENDS = "libffi libxml2 zlib libedit ninja-native llvm-native" 11DEPENDS = "libffi libxml2 zlib zstd libedit ninja-native llvm-native"
12 12
13COMPATIBLE_HOST:riscv64 = "null" 13COMPATIBLE_HOST:riscv64 = "null"
14COMPATIBLE_HOST:riscv32 = "null" 14COMPATIBLE_HOST:riscv32 = "null"
@@ -19,14 +19,14 @@ inherit cmake pkgconfig
19 19
20PROVIDES += "llvm${PV}" 20PROVIDES += "llvm${PV}"
21 21
22PV = "15.0.1" 22PV = "15.0.4"
23 23
24MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}" 24MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
25 25
26LLVM_RELEASE = "${PV}" 26LLVM_RELEASE = "${PV}"
27 27
28BRANCH = "release/${MAJOR_VERSION}.x" 28BRANCH = "release/${MAJOR_VERSION}.x"
29SRCREV = "b73d2c8c720a8c8e6e73b11be4e27afa6cb75bdf" 29SRCREV = "5c68a1cb123161b54b72ce90e7975d95a8eaf2a4"
30SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \ 30SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
31 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ 31 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
32 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ 32 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \