summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index e1d5fc47a1..6413b041a8 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -17,14 +17,14 @@ inherit cmake pkgconfig
17# could be 'rcX' or 'git' or empty ( for release ) 17# could be 'rcX' or 'git' or empty ( for release )
18VER_SUFFIX = "" 18VER_SUFFIX = ""
19 19
20PV = "18.1.2${VER_SUFFIX}" 20PV = "18.1.5${VER_SUFFIX}"
21 21
22MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}" 22MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
23 23
24LLVM_RELEASE = "${PV}" 24LLVM_RELEASE = "${PV}"
25 25
26BRANCH = "release/${MAJOR_VERSION}.x" 26BRANCH = "release/${MAJOR_VERSION}.x"
27SRCREV = "26a1d6601d727a96f4301d0d8647b5a42760ae0c" 27SRCREV = "617a15a9eac96088ae5e9134248d8236e34b91b1"
28SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \ 28SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
29 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ 29 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
30 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ 30 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
@@ -134,7 +134,7 @@ SYSROOT_PREPROCESS_FUNCS:append:class-target = " llvm_sysroot_preprocess"
134 134
135llvm_sysroot_preprocess() { 135llvm_sysroot_preprocess() {
136 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 136 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
137 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 137 install -m 0755 ${UNPACKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
138 ln -sf llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV} 138 ln -sf llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV}
139} 139}
140 140