summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/nativesdk-libtool_2.4.7.bb')
-rw-r--r--meta/recipes-devtools/libtool/nativesdk-libtool_2.4.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.7.bb b/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.7.bb
new file mode 100644
index 0000000000..86c55ded7b
--- /dev/null
+++ b/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.7.bb
@@ -0,0 +1,30 @@
1require libtool-${PV}.inc
2
3FILESEXTRAPATHS =. "${FILE_DIRNAME}/libtool:"
4
5SRC_URI += "file://fixinstall.patch"
6
7inherit nativesdk
8
9S = "${WORKDIR}/libtool-${PV}"
10FILES:${PN} += "${datadir}/libtool/*"
11
12do_configure:prepend () {
13 # Remove any existing libtool m4 since old stale versions would break
14 # any upgrade
15 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
16 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
17}
18
19do_install () {
20 autotools_do_install
21 install -d ${D}${bindir}/
22 install -m 0755 libtool ${D}${bindir}/
23}
24
25SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
26
27libtoolnativesdk_sysroot_preprocess () {
28 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
29 install -m 755 ${D}${bindir}/libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/libtool
30}