summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.7.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.7.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.7.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.7.bb
new file mode 100644
index 0000000000..19024f7830
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.7.bb
@@ -0,0 +1,20 @@
1require libtool-${PV}.inc
2
3DEPENDS = ""
4
5inherit native
6
7EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
8
9do_configure:prepend () {
10 # Remove any existing libtool m4 since old stale versions would break
11 # any upgrade
12 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
13 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
14}
15
16do_install () {
17 autotools_do_install
18 install -d ${D}${bindir}/
19 install -m 0755 libtool ${D}${bindir}/libtool
20}