summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo/librepo_1.15.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/librepo/librepo_1.15.2.bb')
-rw-r--r--meta/recipes-devtools/librepo/librepo_1.15.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_1.15.2.bb b/meta/recipes-devtools/librepo/librepo_1.15.2.bb
new file mode 100644
index 0000000000..995301d601
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo_1.15.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
3HOMEPAGE = "https://github.com/rpm-software-management/librepo"
4DESCRIPTION = "${SUMMARY}"
5LICENSE = "LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = "git://github.com/rpm-software-management/librepo.git;branch=master;protocol=https \
9 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
10 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
11 "
12
13SRCREV = "1a0a5fd2b040d00872118b32d09d1f79730897a2"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
18
19inherit cmake setuptools3-base pkgconfig
20
21EXTRA_OECMAKE = " \
22 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
23 -DPYTHON_DESIRED=3 \
24 -DENABLE_TESTS=OFF \
25 -DENABLE_DOCS=OFF \
26 -DWITH_ZCHUNK=OFF \
27"
28
29BBCLASSEXTEND = "native nativesdk"