summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libdnf/libdnf_0.63.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libdnf/libdnf_0.63.0.bb')
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_0.63.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libdnf/libdnf_0.63.0.bb b/meta/recipes-devtools/libdnf/libdnf_0.63.0.bb
new file mode 100644
index 0000000000..79e8865456
--- /dev/null
+++ b/meta/recipes-devtools/libdnf/libdnf_0.63.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Library providing simplified C and Python API to libsolv"
2HOMEPAGE = "https://github.com/rpm-software-management/libdnf"
3DESCRIPTION = "This library provides a high level package-manager. It's core library of dnf, PackageKit and rpm-ostree. It's replacement for deprecated hawkey library which it contains inside and uses librepo under the hood."
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
7SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master \
8 file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \
9 file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \
10 file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
11 file://0001-Add-WITH_TESTS-option.patch \
12 file://0001-Look-fo-sphinx-only-if-documentation-is-actually-ena.patch \
13 file://enable_test_data_dir_set.patch \
14 file://0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch \
15 "
16
17SRCREV = "669a5c691acba91693d238d6262ac99a440aa9b3"
18UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(?!4\.90)\d+(\.\d+)+)"
19
20S = "${WORKDIR}/git"
21
22DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd json-c swig-native"
23
24inherit gtk-doc gobject-introspection cmake pkgconfig distutils3-base
25
26EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \
27 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \
28 -DWITH_TESTS=OFF \
29 -DWITH_ZCHUNK=OFF \
30 -DWITH_HTML=OFF \
31 "
32EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF"
33EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_GIR=OFF"
34
35BBCLASSEXTEND = "native nativesdk"
36PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
37