summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libcomps/libcomps_0.1.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libcomps/libcomps_0.1.18.bb')
-rw-r--r--meta/recipes-devtools/libcomps/libcomps_0.1.18.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libcomps/libcomps_0.1.18.bb b/meta/recipes-devtools/libcomps/libcomps_0.1.18.bb
new file mode 100644
index 0000000000..8fe43ed0c8
--- /dev/null
+++ b/meta/recipes-devtools/libcomps/libcomps_0.1.18.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
2HOMEPAGE = "https://github.com/rpm-software-management/libcomps"
3DESCRIPTION = "Libcomps is alternative for yum.comps library. It's written in pure C as library and there's bindings for python2 and python3."
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
8 file://0001-Add-crc32.c-to-sources-list.patch \
9 file://0002-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
10 "
11
12SRCREV = "dee4ae37f7818709802de28c4d16fa823bd83ae2"
13
14S = "${WORKDIR}/git"
15
16inherit cmake distutils3-base
17
18DEPENDS += "libxml2 expat libcheck"
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
21OECMAKE_SOURCEPATH = "${S}/libcomps"
22
23BBCLASSEXTEND = "native nativesdk"
24