summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb42
1 files changed, 0 insertions, 42 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
deleted file mode 100644
index d427e98c91..0000000000
--- a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
14DEPENDS += "ncurses flex bison gperf-native"
15RDEPENDS_${PN} += "python3 bash"
16SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends;branch=4.10.x \
17 file://0001-Fix-installation-of-.pc-files.patch \
18 file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch \
19 file://missing-mkdir.patch"
20
21SRCREV = "f8ffe5e1c6f183cb7d5d515aa9381b7557de654e"
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig
26do_configure_prepend () {
27 mkdir -p ${S}/scripts/.autostuff/m4
28}
29
30do_install_append() {
31 ln -s kconfig-conf ${D}${bindir}/conf
32 ln -s kconfig-mconf ${D}${bindir}/mconf
33}
34
35EXTRA_OECONF += "--disable-gconf --disable-qconf"
36
37# Some packages have the version preceeding the .so instead properly
38# versioned .so.<version>, so we need to reorder and repackage.
39SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
40FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
41
42BBCLASSEXTEND = "native"