summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
new file mode 100644
index 0000000000..be90d6b880
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
14DEPENDS += "ncurses flex bison gperf-native"
15RDEPENDS_${PN} += "python3 bash"
16SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends;branch=4.10.x \
17 file://0001-Fix-installation-of-.pc-files.patch \
18 file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
19
20SRCREV = "f8ffe5e1c6f183cb7d5d515aa9381b7557de654e"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig
25do_configure_prepend () {
26 mkdir -p ${S}/scripts/.autostuff/m4
27}
28
29do_install_append() {
30 ln -s kconfig-conf ${D}${bindir}/conf
31 ln -s kconfig-mconf ${D}${bindir}/mconf
32}
33
34EXTRA_OECONF += "--disable-gconf --disable-qconf"
35
36# Some packages have the version preceeding the .so instead properly
37# versioned .so.<version>, so we need to reorder and repackage.
38SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
39FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
40
41BBCLASSEXTEND = "native"