summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.9.0.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.9.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.9.0.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.9.0.bb
new file mode 100644
index 0000000000..53eff30f8b
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.9.0.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The kconfig-frontends project aims at centralising \
5the effort of keeping an up-to-date, out-of-tree, packaging of the \
6kconfig infrastructure, ready for use by third-party projects. \
7The kconfig-frontends package provides the kconfig parser, as well as all \
8the frontends"
9HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
12SECTION = "devel"
13DEPENDS += "ncurses flex bison gperf pkgconfig-native"
14SPIN = ".0"
15SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}${SPIN}.tar.xz"
16
17SRC_URI[md5sum] = "344646587de1bdf965640fff220281bd"
18SRC_URI[sha256sum] = "5d524b238d7dfb63fec782b731af681c5408d74304ef4de38137c542350dd6d6"
19
20S = "${WORKDIR}/${BPN}-${PV}${SPIN}"
21
22inherit autotools
23do_configure_prepend () {
24 mkdir -p scripts/.autostuff/m4
25}
26
27do_install_append() {
28 ln -s kconfig-conf ${D}${bindir}/conf
29 ln -s kconfig-mconf ${D}${bindir}/mconf
30}
31
32EXTRA_OECONF += "--disable-gconf --disable-qconf"
33
34# Some packages have the version preceeding the .so instead properly
35# versioned .so.<version>, so we need to reorder and repackage.
36SOLIBS = "-${PV}.so"
37FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
38
39BBCLASSEXTEND = "native"