summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.8.0.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.8.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.8.0.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.8.0.bb
new file mode 100644
index 0000000000..b9960f9e99
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.8.0.bb
@@ -0,0 +1,40 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The kconfig-frontends project aims at centralising \
5the effort of keeping an up-to-date, out-of-tree, packaging of the \
6kconfig infrastructure, ready for use by third-party projects. \
7The kconfig-frontends package provides the kconfig parser, as well as all \
8the frontends"
9HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
12SECTION = "devel"
13DEPENDS += "ncurses flex bison gperf pkgconfig-native"
14PR = "r0"
15SPIN = ".0"
16SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}${SPIN}.tar.xz"
17
18SRC_URI[md5sum] = "73598aea99d01d9c422b335e9b963271"
19SRC_URI[sha256sum] = "b3ff325338aa291c9129dbf33c69ff321e30105aa06ff957be6f958acdc72b42"
20
21S = "${WORKDIR}/${BPN}-${PV}${SPIN}"
22
23inherit autotools
24do_configure_prepend () {
25 mkdir -p scripts/.autostuff/m4
26}
27
28do_install_append() {
29 ln -s kconfig-conf ${D}${bindir}/conf
30 ln -s kconfig-mconf ${D}${bindir}/mconf
31}
32
33EXTRA_OECONF += "--disable-gconf --disable-qconf"
34
35# Some packages have the version preceeding the .so instead properly
36# versioned .so.<version>, so we need to reorder and repackage.
37SOLIBS = "-${PV}.so"
38FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
39
40BBCLASSEXTEND = "native"