summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
new file mode 100644
index 0000000000..277de03200
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
@@ -0,0 +1,34 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The kconfig-frontends project aims at centralising \
5the effort of keeping an up-to-date, out-of-tree, packaging of the \
6kconfig infrastructure, ready for use by third-party projects. \
7The kconfig-frontends package provides the kconfig parser, as well as all \
8the frontends"
9HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
12SECTION = "devel"
13DEPENDS += "ncurses flex bison gperf"
14PR = "r0"
15PV = "3.5.0"
16SPIN = "0"
17SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
18SRC_URI[md5sum] = "0e476b35f321234e0c2bea953461b46f"
19SRC_URI[sha256sum] = "567a556db5dc5f5c63e9d9fc9a45918ce870e3423407715a495e11b67e70b2f2"
20
21S = "${WORKDIR}/${BPN}-${PV}-${SPIN}"
22
23inherit autotools
24do_configure_prepend () {
25 mkdir -p scripts/.autostuff/m4
26}
27EXTRA_OECONF += "--disable-gconf --disable-qconf"
28
29# Some packages have the version preceeding the .so instead properly
30# versioned .so.<version>, so we need to reorder and repackage.
31SOLIBS = "-${PV}.so"
32FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
33
34BBCLASSEXTEND = "native"