summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-08-24 13:12:13 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-25 14:46:58 +0100
commitd04f754bce8525ba35dc25eb1c92eb6143e3ec1f (patch)
tree00d83c438641e6758038f5e910a936b70d2f1f96 /meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
parentc33cfc6a8058c195e805c8fabc201db0dca60843 (diff)
downloadpoky-d04f754bce8525ba35dc25eb1c92eb6143e3ec1f.tar.gz
kconfig-frontends: upgrade to 3.5
(From OE-Core rev: 512fdcbaea71711f75a7389c14319dbf865cdfaf) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
new file mode 100644
index 0000000000..277de03200
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
@@ -0,0 +1,34 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The kconfig-frontends project aims at centralising \
5the effort of keeping an up-to-date, out-of-tree, packaging of the \
6kconfig infrastructure, ready for use by third-party projects. \
7The kconfig-frontends package provides the kconfig parser, as well as all \
8the frontends"
9HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
12SECTION = "devel"
13DEPENDS += "ncurses flex bison gperf"
14PR = "r0"
15PV = "3.5.0"
16SPIN = "0"
17SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
18SRC_URI[md5sum] = "0e476b35f321234e0c2bea953461b46f"
19SRC_URI[sha256sum] = "567a556db5dc5f5c63e9d9fc9a45918ce870e3423407715a495e11b67e70b2f2"
20
21S = "${WORKDIR}/${BPN}-${PV}-${SPIN}"
22
23inherit autotools
24do_configure_prepend () {
25 mkdir -p scripts/.autostuff/m4
26}
27EXTRA_OECONF += "--disable-gconf --disable-qconf"
28
29# Some packages have the version preceeding the .so instead properly
30# versioned .so.<version>, so we need to reorder and repackage.
31SOLIBS = "-${PV}.so"
32FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
33
34BBCLASSEXTEND = "native"