summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.16.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.16.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.16.bb b/meta/recipes-devtools/json-c/json-c_0.16.bb
new file mode 100644
index 0000000000..fdec5ec9af
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.16.bb
@@ -0,0 +1,18 @@
1SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
8
9SRC_URI[sha256sum] = "8e45ac8f96ec7791eaf3bb7ee50e9c2100bbbc87b8d0f1d030c5ba8a0288d96b"
10
11UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/tags"
12UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+"
13
14RPROVIDES:${PN} = "libjson"
15
16inherit cmake
17
18BBCLASSEXTEND = "native nativesdk"