summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/insserv/insserv_1.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/insserv/insserv_1.14.0.bb')
-rw-r--r--meta/recipes-devtools/insserv/insserv_1.14.0.bb42
1 files changed, 0 insertions, 42 deletions
diff --git a/meta/recipes-devtools/insserv/insserv_1.14.0.bb b/meta/recipes-devtools/insserv/insserv_1.14.0.bb
deleted file mode 100644
index b66e98b49f..0000000000
--- a/meta/recipes-devtools/insserv/insserv_1.14.0.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1SUMMARY = "Boot sequence organizer using LSB init.d dependencies"
2DESCRIPTION = "This utility reorders the init.d boot scripts based on dependencies given in scripts' LSB comment \
3headers, or in override files included in this package or added in /etc/insserv."
4# There is no known home page for insserv
5SECTION = "base"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8
9PR = "r1"
10
11SRC_URI = "ftp://ftp.suse.com/pub/projects/init/${BPN}-${PV}.tar.bz2 \
12 file://makefile.patch \
13 file://disable_runtests.patch \
14 file://161_bts777914_fix_undeclared_identifier.patch \
15 file://insserv.conf \
16 file://run-ptest \
17"
18
19SRC_URI[md5sum] = "4a97d900855148842b1aa8f33b988b47"
20SRC_URI[sha256sum] = "89a0a093b1cf3d802ad40568e64b496b493f51ff9825905c8bd12738b374ca47"
21
22do_install () {
23 oe_runmake 'DESTDIR=${D}' install
24 install -m0644 ${WORKDIR}/insserv.conf ${D}${sysconfdir}/insserv.conf
25}
26
27do_install_class-native () {
28 oe_runmake 'DESTDIR=${D}/${STAGING_DIR_NATIVE}' install
29 install -m0644 ${WORKDIR}/insserv.conf ${D}${sysconfdir}/insserv.conf
30}
31
32BBCLASSEXTEND = "native"
33
34inherit ptest
35
36do_install_ptest() {
37 for i in common suite; do cp ${S}/tests/$i ${D}${PTEST_PATH}; done
38 sed -e 's|${\PWD}/insserv|insserv|;/trap/d' -i ${D}${PTEST_PATH}/suite
39 sed -e '/test_simple_sequence$/d;/test_undetected_loop$/d' -i ${D}${PTEST_PATH}/common
40}
41
42RDEPENDS_${PN}-ptest += "bash"