summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man-native_1.43.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man-native_1.43.2.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.43.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.43.2.bb b/meta/recipes-devtools/help2man/help2man-native_1.43.2.bb
new file mode 100644
index 0000000000..22b235e3b4
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.43.2.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Program to create simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "bd816983f068ebcf8ca7a20463f7337d"
10SRC_URI[sha256sum] = "ec43eb74669e02cb61af142f1398bb882ff1dbbc9a8cc4f8cd70098fe425e4a9"
11
12inherit autotools native
13
14EXTRA_OECONF = "--disable-nls"
15
16# We don't want to reconfigure things as it would require 'perlnative' to be
17# used.
18do_configure() {
19 oe_runconf
20}
21
22do_install_append () {
23 # Make sure we use /usr/bin/env perl
24 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
25}