summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-crosssdk_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-crosssdk_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-crosssdk_1.9.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-crosssdk_1.9.bb b/meta/recipes-devtools/go/go-crosssdk_1.9.bb
index 1857c8a577..3ac629bd41 100644
--- a/meta/recipes-devtools/go/go-crosssdk_1.9.bb
+++ b/meta/recipes-devtools/go/go-crosssdk_1.9.bb
@@ -1,2 +1,11 @@
1require go-crosssdk.inc 1require go-crosssdk.inc
2require go-${PV}.inc 2require go-${PV}.inc
3
4export CC_FOR_TARGET = "${TARGET_PREFIX}gcc ${TARGET_CC_ARCH} --sysroot=${STAGING_DIR_TARGET}"
5export CXX_FOR_TARGET = "${TARGET_PREFIX}g++ ${TARGET_CC_ARCH} --sysroot=${STAGING_DIR_TARGET}"
6export GO_INSTALL = "cmd"
7
8do_compile_prepend() {
9 export GOBIN="${B}/bin"
10 export TMPDIR="$GOTMPDIR"
11}