summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-binary-native_1.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.20.bb')
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.20.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.20.bb b/meta/recipes-devtools/go/go-binary-native_1.20.bb
new file mode 100644
index 0000000000..ee6b84c4f5
--- /dev/null
+++ b/meta/recipes-devtools/go/go-binary-native_1.20.bb
@@ -0,0 +1,48 @@
1# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
10# Checksums available at https://go.dev/dl/
11SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
12SRC_URI[go_linux_amd64.sha256sum] = "5a9ebcc65c1cce56e0d2dc616aff4c4cedcfbda8cc6f0288cc08cda3b18dcbf1"
13SRC_URI[go_linux_arm64.sha256sum] = "17700b6e5108e2a2c3b1a43cd865d3f9c66b7f1c5f0cec26d3672cc131cc0994"
14SRC_URI[go_linux_ppc64le.sha256sum] = "bccbf89c83e0aab2911e57217159bf0fc49bb07c6eebd2c23ae30af18fc5368b"
15
16UPSTREAM_CHECK_URI = "https://golang.org/dl/"
17UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
18
19S = "${WORKDIR}/go"
20
21inherit goarch native
22
23do_compile() {
24 :
25}
26
27make_wrapper() {
28 rm -f ${D}${bindir}/$1
29 cat <<END >${D}${bindir}/$1
30#!/bin/bash
31here=\`dirname \$0\`
32export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
33\$here/../lib/go/bin/$1 "\$@"
34END
35 chmod +x ${D}${bindir}/$1
36}
37
38do_install() {
39 find ${S} -depth -type d -name testdata -exec rm -rf {} +
40
41 install -d ${D}${bindir} ${D}${libdir}/go
42 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
43
44 for f in ${S}/bin/*
45 do
46 make_wrapper `basename $f`
47 done
48}