summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/glide/glide_0.13.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/glide/glide_0.13.3.bb')
-rw-r--r--meta/recipes-devtools/glide/glide_0.13.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/glide/glide_0.13.3.bb b/meta/recipes-devtools/glide/glide_0.13.3.bb
new file mode 100644
index 0000000000..ebad0ec60a
--- /dev/null
+++ b/meta/recipes-devtools/glide/glide_0.13.3.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Vendor Package Management for Golang"
2HOMEPAGE = "https://glide.sh"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=54905cf894f8cc416a92f4fc350c35b2"
5
6GO_IMPORT = "github.com/Masterminds/glide"
7SRC_URI = "git://${GO_IMPORT}"
8SRCREV = "8ed5b9292379d86c39592a7e6a58eb9c903877cf"
9
10inherit go
11
12RDEPENDS_${PN}-dev += "bash"
13RDEPENDS_${PN}-ptest += "bash"
14
15BBCLASSEXTEND = "native nativesdk"
16
17# for x86 ends with textrel in ${PN}
18# http://errors.yoctoproject.org/Errors/Details/185631/
19# ERROR: QA Issue: ELF binary '/work/i586-oe-linux/glide/0.13.1-r0/packages-split/glide/usr/bin/glide' has relocations in .text [textrel]
20INSANE_SKIP_${PN} += "textrel"
21
22# for aarch64 ends with textrel in ${PN}-ptest
23# http://errors.yoctoproject.org/Errors/Details/185633/
24# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/glide.test' has relocations in .text
25# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/dependency/dependency.test' has relocations in .text
26# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/repo/repo.test' has relocations in .text
27# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/mirrors/mirrors.test' has relocations in .text
28# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cfg/cfg.test' has relocations in .text
29# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/godep/strip/strip.test' has relocations in .text
30# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/path/path.test' has relocations in .text
31# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/tree/tree.test' has relocations in .text
32# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/util/util.test' has relocations in .text
33# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/action/action.test' has relocations in .text
34# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cache/cache.test' has relocations in .text [textrel]
35INSANE_SKIP_${PN}-ptest += "textrel"
36
37# fails to run task compile_ptest_base on mips
38PTEST_ENABLED_mipsarch = "0"