summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_9.2.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_9.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_9.2.bb b/meta/recipes-devtools/gdb/gdb_9.2.bb
new file mode 100644
index 0000000000..d70757a151
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_9.2.bb
@@ -0,0 +1,28 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python3-dir
5
6EXTRA_OEMAKE_append_libc-musl = "\
7 gt_cv_func_gnugettext1_libc=yes \
8 gt_cv_func_gnugettext2_libc=yes \
9 gl_cv_func_working_strerror=yes \
10 gl_cv_func_strerror_0_works=yes \
11 gl_cv_func_gettimeofday_clobber=no \
12 "
13
14do_configure_prepend() {
15 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
16 cat > ${WORKDIR}/python << EOF
17#!/bin/sh
18case "\$2" in
19 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
20 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
21 --exec-prefix) echo "${exec_prefix}" ;;
22 *) exit 1 ;;
23esac
24exit 0
25EOF
26 chmod +x ${WORKDIR}/python
27 fi
28}