summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.6.2.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.6.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.6.2.bb b/meta/recipes-devtools/gdb/gdb_7.6.2.bb
new file mode 100644
index 0000000000..e86447121b
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.6.2.bb
@@ -0,0 +1,23 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python-dir
5
6PACKAGECONFIG ??= ""
7PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
8
9do_configure_prepend() {
10 if [ -n "${@base_contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
11 cat > ${WORKDIR}/python << EOF
12#!/bin/sh
13case "\$2" in
14 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
15 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
16 --exec-prefix) echo "${exec_prefix}" ;;
17 *) exit 1 ;;
18esac
19exit 0
20EOF
21 chmod +x ${WORKDIR}/python
22 fi
23}