summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.1.bb b/meta/recipes-devtools/gdb/gdb_7.11.1.bb
new file mode 100644
index 0000000000..57cffc9983
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.11.1.bb
@@ -0,0 +1,26 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python3-dir
5
6EXTRA_OEMAKE_append_libc-musl = "\
7 gt_cv_func_gnugettext1_libc=yes \
8 gt_cv_func_gnugettext2_libc=yes \
9 "
10
11do_configure_prepend() {
12 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
13 cat > ${WORKDIR}/python << EOF
14#!/bin/sh
15case "\$2" in
16 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
17 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
18 --exec-prefix) echo "${exec_prefix}" ;;
19 *) exit 1 ;;
20esac
21exit 0
22EOF
23 chmod +x ${WORKDIR}/python
24 fi
25}
26CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"