summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/flex/flex_2.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/flex/flex_2.6.2.bb')
-rw-r--r--meta/recipes-devtools/flex/flex_2.6.2.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/flex/flex_2.6.2.bb b/meta/recipes-devtools/flex/flex_2.6.2.bb
new file mode 100644
index 0000000000..1780cabbff
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex_2.6.2.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD"
7
8DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
9
10BBCLASSEXTEND = "native nativesdk"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
13
14SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
15 file://crosscompile.patch;apply=1 \
16 file://run-ptest \
17 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
18 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
19 "
20
21SRC_URI[md5sum] = "cc6d76c333db7653d5caf423a3335239"
22SRC_URI[sha256sum] = "9a01437a1155c799b7dc2508620564ef806ba66250c36bf5f9034b1c207cb2c9"
23
24# Flex has moved to github from 2.6.1 onwards
25UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
26UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
27
28inherit autotools gettext texinfo ptest
29
30M4 = "${bindir}/m4"
31M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
32EXTRA_OECONF += "ac_cv_path_M4=${M4}"
33EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
34
35EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
36
37do_install_append_class-native() {
38 create_wrapper ${D}/${bindir}/flex M4=${M4}
39}
40
41do_install_append_class-nativesdk() {
42 create_wrapper ${D}/${bindir}/flex M4=${M4}
43}
44
45RDEPENDS_${PN} += "m4"
46RDEPENDS_${PN}-ptest += "bash gawk"
47
48do_compile_ptest() {
49 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
50}
51
52do_install_ptest() {
53 mkdir -p ${D}${PTEST_PATH}/build-aux/
54 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
55 cp -r ${S}/tests/* ${D}${PTEST_PATH}
56 cp -r ${B}/tests/* ${D}${PTEST_PATH}
57 sed -e 's/^Makefile:/_Makefile:/' \
58 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
59 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
60 -i ${D}${PTEST_PATH}/Makefile
61}