summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.29.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.29.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.29.bb b/meta/recipes-devtools/file/file_5.29.bb
new file mode 100644
index 0000000000..29af874815
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.29.bb
@@ -0,0 +1,48 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14# Blacklist a bogus tag in upstream check
15UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
16
17SRC_URI = "git://github.com/file/file.git \
18 file://debian-742262.patch \
19 file://0001-Add-P-prompt-into-Usage-info.patch \
20 "
21
22SRCREV = "015b0cdce1a0abb68ab99510e7fc8d2f77e8ec77"
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
28EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
29
30CFLAGS_append = " -std=c99"
31
32FILES_${PN} += "${datadir}/misc/*.mgc"
33
34do_install_append_class-native() {
35 create_cmdline_wrapper ${D}/${bindir}/file \
36 --magic-file ${datadir}/misc/magic.mgc
37}
38
39do_install_append_class-nativesdk() {
40 create_cmdline_wrapper ${D}/${bindir}/file \
41 --magic-file ${datadir}/misc/magic.mgc
42}
43
44BBCLASSEXTEND = "native nativesdk"
45PROVIDES_append_class-native = " file-replacement-native"
46# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
47# depends on file-replacement-native.
48bindir_append_class-native = "/file-native"