summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.28.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.28.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.28.bb b/meta/recipes-devtools/file/file_5.28.bb
new file mode 100644
index 0000000000..516c8c55be
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.28.bb
@@ -0,0 +1,46 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14# Blacklist a bogus tag in upstream check
15UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
16
17SRC_URI = "git://github.com/file/file.git \
18 file://debian-742262.patch \
19 file://0001-Add-P-prompt-into-Usage-info.patch \
20 "
21
22SRCREV = "3c521817322a6bf5160cfeb09b9145ccde587b2a"
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
28EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
29
30FILES_${PN} += "${datadir}/misc/*.mgc"
31
32do_install_append_class-native() {
33 create_cmdline_wrapper ${D}/${bindir}/file \
34 --magic-file ${datadir}/misc/magic.mgc
35}
36
37do_install_append_class-nativesdk() {
38 create_cmdline_wrapper ${D}/${bindir}/file \
39 --magic-file ${datadir}/misc/magic.mgc
40}
41
42BBCLASSEXTEND = "native nativesdk"
43PROVIDES_append_class-native = " file-replacement-native"
44# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
45# depends on file-replacement-native.
46bindir_append_class-native = "/file-native"