summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb')
-rw-r--r--meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb b/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
deleted file mode 100644
index 2d2604f270..0000000000
--- a/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "Provides a fake \"root environment\" by means of LD_PRELOAD and SYSV IPC or TCP trickery"
2HOMEPAGE = "http://fakeroot.alioth.debian.org/"
3SECTION = "base"
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
6
7# fakeroot needs getopt which is provided by the util-linux package
8RDEPENDS = "util-linux"
9RDEPENDS_virtclass-native = "util-linux-native"
10PR = "r0"
11PROVIDES += "virtual/fakeroot"
12
13SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
14 file://absolutepaths.patch"
15
16inherit autotools
17
18do_configure_prepend() {
19 # fakeroot's own bootstrap includes other autoreconf stuff we don't need here
20 # so manually create the aux directory
21 mkdir -p ${S}/build-aux
22}
23
24do_install_append() {
25 install -d ${D}${includedir}/fakeroot/
26 install -m 644 *.h ${D}${includedir}/fakeroot
27}
28
29# Compatability for the rare systems not using or having SYSV
30python () {
31 if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
32 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
33}
34
35BBCLASSEXTEND = "native"
36
37SRC_URI[md5sum] = "659a1f3a36554abfc2a3eaad2fdc0604"
38SRC_URI[sha256sum] = "b035c834944bf9482027f48c388de8492e96609825265ac03f05408d0b3aae68"