summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.176.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.176.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.176.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.176.bb b/meta/recipes-devtools/elfutils/elfutils_0.176.bb
index fb2868723a..19d27cd992 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.176.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.176.bb
@@ -30,7 +30,7 @@ SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
30 file://debian/testsuite-ignore-elflint.diff \ 30 file://debian/testsuite-ignore-elflint.diff \
31 file://0001-skip-the-test-when-gcc-not-deployed.patch \ 31 file://0001-skip-the-test-when-gcc-not-deployed.patch \
32 file://run-ptest \ 32 file://run-ptest \
33 file://serial-tests.patch \ 33 file://ptest.patch \
34 " 34 "
35SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch \ 35SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch \
36 file://0001-fix-err-variable-and-function-conflicts.patch \ 36 file://0001-fix-err-variable-and-function-conflicts.patch \
@@ -43,10 +43,9 @@ inherit autotools gettext ptest
43 43
44EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 44EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
45EXTRA_OECONF_append_class-native = " --without-bzlib" 45EXTRA_OECONF_append_class-native = " --without-bzlib"
46# gcc has been added to blacklist, we will find workaround solution 46RDEPENDS_${PN}-ptest = "libasm libelf bash make coreutils ${PN}-binutils ${PN}"
47RDEPENDS_${PN}-ptest = "libasm libelf bash"
48 47
49EXTRA_OECONF_append_class-target += "--enable-tests-rpath" 48EXTRA_OECONF_append_class-target += "--disable-tests-rpath"
50 49
51do_install_append() { 50do_install_append() {
52 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then 51 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
@@ -56,14 +55,13 @@ do_install_append() {
56 55
57do_compile_ptest() { 56do_compile_ptest() {
58 cd ${B}/tests 57 cd ${B}/tests
59 oe_runmake buildtest-TESTS 58 oe_runmake buildtest-TESTS oecheck
60} 59}
61 60
62do_install_ptest() { 61do_install_ptest() {
63 if [ ${PTEST_ENABLED} = "1" ]; then 62 if [ ${PTEST_ENABLED} = "1" ]; then
64 cp -r ${S}/tests/ ${D}${PTEST_PATH} 63 cp -r ${S}/tests/ ${D}${PTEST_PATH}
65 cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests 64 cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests
66 cp -r ${B}/src ${D}${PTEST_PATH}
67 cp -r ${B}/config.h ${D}${PTEST_PATH} 65 cp -r ${B}/config.h ${D}${PTEST_PATH}
68 cp -r ${B}/backends ${D}${PTEST_PATH} 66 cp -r ${B}/backends ${D}${PTEST_PATH}
69 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile 67 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile