summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.172.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.172.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.172.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.172.bb b/meta/recipes-devtools/elfutils/elfutils_0.172.bb
new file mode 100644
index 0000000000..04f6709d5a
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils_0.172.bb
@@ -0,0 +1,74 @@
1SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts "
8# The Debian patches below are from:
9# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.170-0.5.debian.tar.xz
10SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
11 file://0001-dso-link-change.patch \
12 file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
13 file://0003-fixheadercheck.patch \
14 file://0004-Disable-the-test-to-convert-euc-jp.patch \
15 file://0005-fix-a-stack-usage-warning.patch \
16 file://0006-Fix-build-on-aarch64-musl.patch \
17 file://0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch \
18 file://0001-libasm-may-link-with-libbz2-if-found.patch \
19 file://debian/0001-hppa_backend.patch \
20 file://debian/0001-arm_backend.patch \
21 file://debian/0001-mips_backend.patch \
22 file://debian/0001-testsuite-ignore-elflint.patch \
23 file://debian/0001-mips_readelf_w.patch \
24 file://debian/kfreebsd_path.patch \
25 file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \
26 file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
27 file://debian/0003-Add-mips-n64-relocation-format-hack.patch \
28 file://debian/hurd_path.patch \
29 file://debian/ignore_strmerge.diff \
30 file://debian/0001-fix-gcc7-ftbfs.patch \
31 file://debian/0001-disable_werror.patch \
32 "
33SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch"
34SRC_URI[md5sum] = "01e87ab4c5a6a249c04e22a97a4221d3"
35SRC_URI[sha256sum] = "779c99e6344c4982bbab60b8d276cec3d468151c758905f9a44ba6b6edaa0e24"
36
37inherit autotools gettext
38
39EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
40EXTRA_OECONF_append_class-native = " --without-bzlib"
41
42do_install_append() {
43 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
44 rm -f ${D}${bindir}/eu-objdump
45 fi
46}
47
48EXTRA_OEMAKE_class-native = ""
49EXTRA_OEMAKE_class-nativesdk = ""
50
51ALLOW_EMPTY_${PN}_libc-musl = "1"
52
53BBCLASSEXTEND = "native nativesdk"
54
55# Package utilities separately
56PACKAGES =+ "${PN}-binutils libelf libasm libdw"
57FILES_${PN}-binutils = "\
58 ${bindir}/eu-addr2line \
59 ${bindir}/eu-ld \
60 ${bindir}/eu-nm \
61 ${bindir}/eu-readelf \
62 ${bindir}/eu-size \
63 ${bindir}/eu-strip"
64
65FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
66FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
67FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
68# Some packages have the version preceeding the .so instead properly
69# versioned .so.<version>, so we need to reorder and repackage.
70#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
71#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
72
73# The package contains symlinks that trip up insane
74INSANE_SKIP_${MLPREFIX}libdw = "dev-so"