summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_3.3.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.3.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.3.bb b/meta/recipes-devtools/distcc/distcc_3.3.bb
new file mode 100644
index 0000000000..40648e2142
--- /dev/null
+++ b/meta/recipes-devtools/distcc/distcc_3.3.bb
@@ -0,0 +1,69 @@
1SUMMARY = "A parallel build system"
2DESCRIPTION = "distcc is a parallel build system that distributes \
3compilation of C/C++/ObjC code across machines on a network."
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8DEPENDS = "avahi binutils"
9
10PACKAGECONFIG ??= "popt"
11PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
12# use system popt by default
13PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
14
15RRECOMMENDS_${PN} = "avahi-daemon"
16
17SRC_URI = "git://github.com/distcc/distcc.git \
18 file://separatebuilddir.patch \
19 file://default \
20 file://distccmon-gnome.desktop \
21 file://distcc \
22 file://distcc.service"
23SRCREV = "002e68b766ccd7ad05551e67d162b71a7a773d0d"
24S = "${WORKDIR}/git"
25
26inherit autotools pkgconfig update-rc.d useradd systemd
27
28EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
29
30USERADD_PACKAGES = "${PN}"
31USERADD_PARAM_${PN} = "--system \
32 --home /dev/null \
33 --no-create-home \
34 --gid nogroup \
35 distcc"
36
37INITSCRIPT_NAME = "distcc"
38
39SYSTEMD_PACKAGES = "${PN}"
40SYSTEMD_SERVICE_${PN} = "distcc.service"
41
42do_install() {
43 # Improve reproducibility: compress w/o timestamps
44 oe_runmake 'DESTDIR=${D}' "GZIP_BIN=gzip -n" install
45 install -d ${D}${sysconfdir}/init.d/
46 install -d ${D}${sysconfdir}/default
47 install -m 0755 ${WORKDIR}/distcc ${D}${sysconfdir}/init.d/
48 install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/distcc
49 install -d ${D}${systemd_unitdir}/system/
50 install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system
51 sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
52 ${DESKTOPINSTALL}
53}
54DESKTOPINSTALL = ""
55DESKTOPINSTALL_libc-glibc () {
56 install -d ${D}${datadir}/distcc/
57 install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
58}
59PACKAGES += "distcc-distmon-gnome"
60
61FILES_${PN} = " ${sysconfdir} \
62 ${bindir}/distcc \
63 ${bindir}/lsdistcc \
64 ${bindir}/distccd \
65 ${bindir}/distccmon-text \
66 ${sbindir}/update-distcc-symlinks \
67 ${systemd_unitdir}/system/distcc.service"
68FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
69 ${datadir}/distcc"