summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat/diffstat_1.64.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/diffstat/diffstat_1.64.bb')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.64.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.64.bb b/meta/recipes-devtools/diffstat/diffstat_1.64.bb
new file mode 100644
index 0000000000..76ca30c20a
--- /dev/null
+++ b/meta/recipes-devtools/diffstat/diffstat_1.64.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=f605b1986cc3b808ec0e4fa9d0e0f2d9"
9
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
13 file://0001-aclocal.m4-add-missing-header-defines.patch \
14 "
15
16SRC_URI[sha256sum] = "b8aee38d9d2e1d05926e6b55810a9d2c2dd407f24d6a267387563a4436e3f7fc"
17
18inherit autotools gettext ptest
19
20EXTRA_AUTORECONF += "--exclude=aclocal"
21
22LDFLAGS += "${TOOLCHAIN_OPTIONS}"
23
24do_install_ptest() {
25 cp -r ${S}/testing ${D}${PTEST_PATH}
26}
27
28BBCLASSEXTEND = "nativesdk"