diff options
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_1.1.1.bb')
-rw-r--r-- | meta/recipes-devtools/createrepo-c/createrepo-c_1.1.1.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.1.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.1.bb new file mode 100644 index 0000000000..e6714629af --- /dev/null +++ b/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.1.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "C implementation of createrepo." | ||
2 | HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki" | ||
3 | |||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | SRC_URI = "git://github.com/rpm-software-management/createrepo_c;branch=master;protocol=https \ | ||
8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
9 | file://0001-include-rpm-rpmstring.h.patch \ | ||
10 | " | ||
11 | |||
12 | SRCREV = "78b0c3ff48bd58eb9c0a72879cf1025e9f225684" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm" | ||
17 | DEPENDS:append:class-native = " file-replacement-native" | ||
18 | |||
19 | inherit cmake pkgconfig bash-completion setuptools3-base | ||
20 | |||
21 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF" | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | ||
24 | |||
25 | # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in | ||
26 | do_install:append:class-native() { | ||
27 | create_wrapper ${D}/${bindir}/createrepo_c \ | ||
28 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
29 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc | ||
30 | create_wrapper ${D}/${bindir}/modifyrepo_c \ | ||
31 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc | ||
32 | } | ||
33 | |||
34 | do_install:append:class-nativesdk() { | ||
35 | create_wrapper ${D}/${bindir}/createrepo_c \ | ||
36 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \ | ||
37 | MAGIC=${datadir}/misc/magic.mgc | ||
38 | create_wrapper ${D}/${bindir}/modifyrepo_c \ | ||
39 | MAGIC=${datadir}/misc/magic.mgc | ||
40 | rm -rf ${D}/etc | ||
41 | } | ||