summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.5.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.5.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.5.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.5.bb
new file mode 100644
index 0000000000..60585fe580
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.5.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 "
10
11SRCREV = "ab96d490bc2f606570030fe50302d466fce8f346"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
16DEPENDS:append:class-native = " file-replacement-native"
17
18inherit cmake pkgconfig bash-completion distutils3-base
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
21
22BBCLASSEXTEND = "native nativesdk"
23
24# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
25do_install:append:class-native() {
26 create_wrapper ${D}/${bindir}/createrepo_c \
27 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
28 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
29 create_wrapper ${D}/${bindir}/modifyrepo_c \
30 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
31}
32
33do_install:append:class-nativesdk() {
34 create_wrapper ${D}/${bindir}/createrepo_c \
35 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
36 MAGIC=${datadir}/misc/magic.mgc
37 create_wrapper ${D}/${bindir}/modifyrepo_c \
38 MAGIC=${datadir}/misc/magic.mgc
39 rm -rf ${D}/etc
40}