summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.9.5.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.9.5.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.9.5.bb b/meta/recipes-devtools/cmake/cmake-native_3.9.5.bb
new file mode 100644
index 0000000000..e55e8b1cf6
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.9.5.bb
@@ -0,0 +1,38 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
21 -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
22 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
23 -DHAVE_SYS_ACL_H=0 \
24"
25
26do_configure () {
27 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
28}
29
30do_compile() {
31 oe_runmake
32}
33
34do_install() {
35 oe_runmake 'DESTDIR=${D}' install
36}
37
38do_compile[progress] = "percent"