summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.6.3.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.6.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.6.3.bb b/meta/recipes-devtools/ccache/ccache_4.6.3.bb
new file mode 100644
index 0000000000..5ed46cdc19
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_4.6.3.bb
@@ -0,0 +1,28 @@
1SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=7a19377a02749d8a1281ed608169b0ee"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
15 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
16 "
17SRC_URI[sha256sum] = "f46ba3706ad80c30d4d5874dee2bf9227a7fcd0ccaac31b51919a3053d84bd05"
18
19UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
20
21inherit cmake
22
23PATCHTOOL = "patch"
24
25BBCLASSEXTEND = "native nativesdk"
26
27PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
28PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"