summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.5.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.5.bb b/meta/recipes-devtools/ccache/ccache_4.5.bb
new file mode 100644
index 0000000000..a98bb43ead
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_4.5.bb
@@ -0,0 +1,26 @@
1SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=8fe0fdfdc7a892516526b86c28d06a16"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
15SRC_URI[sha256sum] = "8f1c6495a06ae0a9ff311c9d43096233702a2045c476ca1ae393b434abf1f528"
16
17UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
18
19inherit cmake
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"
24
25PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
26PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"