summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.12.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_5.12.1.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_5.12.1.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.12.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.12.1.bb
new file mode 100644
index 0000000000..3fc959bf8e
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.12.1.bb
@@ -0,0 +1,71 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2 & LGPLv2.1+"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
13 file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \
14"
15SECTION = "base"
16DEPENDS = "lzo util-linux zlib"
17DEPENDS_append_class-target = " udev"
18
19SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
20 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
21 "
22SRCREV = "96d77fcefdd3b9fd297b5aabbce6dc43e2315ee2"
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG ??= " \
26 programs \
27 convert \
28 python \
29 crypto-builtin \
30"
31PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
32PACKAGECONFIG[programs] = "--enable-programs,--disable-programs"
33PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs"
34PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned"
35PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
36PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
37
38# Pick only one crypto provider
39PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin"
40PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt"
41PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium"
42PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi"
43
44inherit autotools-brokensep pkgconfig manpages
45inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)}
46
47CLEANBROKEN = "1"
48
49EXTRA_OECONF = "--enable-largefile"
50EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
51EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
52EXTRA_PYTHON_CFLAGS_class-native = ""
53EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
54EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
55
56do_configure_prepend() {
57 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
58 mkdir -p ${S}/config
59 cp -f $(automake --print-libdir)/install-sh ${S}/config/
60}
61
62
63do_install_append() {
64 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
65 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
66 fi
67}
68
69RDEPENDS_${PN} = "libgcc"
70
71BBCLASSEXTEND = "native nativesdk"