summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_5.11.1.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_5.11.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.11.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.11.1.bb
new file mode 100644
index 0000000000..2ab476a88e
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.11.1.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2 & LGPLv3+"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
13 file://libbtrfsutil/COPYING.LESSER;md5=3000208d539ec061b899bce1d9ce9404 \
14"
15SECTION = "base"
16DEPENDS = "util-linux attr e2fsprogs lzo acl"
17DEPENDS_append_class-target = " udev"
18RDEPENDS_${PN} = "libgcc"
19
20SRCREV = "8d5051f279f7994fb80536ef8f846f06d121d898"
21SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
22 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
23 "
24
25PACKAGECONFIG ??= "python"
26PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
27PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
28PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
29
30inherit autotools-brokensep pkgconfig manpages
31inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)}
32
33CLEANBROKEN = "1"
34
35EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
36EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
37EXTRA_PYTHON_CFLAGS_class-native = ""
38EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
39EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
40
41do_configure_prepend() {
42 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
43 mkdir -p ${S}/config
44 cp -f $(automake --print-libdir)/install-sh ${S}/config/
45}
46
47S = "${WORKDIR}/git"
48
49do_install_append() {
50 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
51 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
52 fi
53}
54
55BBCLASSEXTEND = "native nativesdk"