summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb
new file mode 100644
index 0000000000..a7b42e9546
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "88221fc081a7a0979a012f243b66cf097382cc8f"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
19
20inherit autotools-brokensep pkgconfig manpages
21
22PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
23EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
24
25do_configure_prepend() {
26 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
27 mkdir -p ${S}/config
28 cp -f $(automake --print-libdir)/install-sh ${S}/config/
29}
30
31S = "${WORKDIR}/git"
32
33BBCLASSEXTEND = "native"