summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.8.1.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.8.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.8.1.bb b/meta/recipes-devtools/bison/bison_3.8.1.bb
new file mode 100644
index 0000000000..a6159b007a
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.8.1.bb
@@ -0,0 +1,52 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://add-with-bisonlocaledir.patch \
14 "
15SRC_URI[sha256sum] = "31fc602488aad6bdecf0ccc556e0fc72fc57cdc595cf92398f020e0cf4980f15"
16
17inherit autotools gettext texinfo
18
19# No point in hardcoding path to m4, just use PATH
20CACHED_CONFIGUREVARS = "ac_cv_path_M4=m4"
21
22PACKAGECONFIG ??= "readline ${@ 'textstyle' if d.getVar('USE_NLS') == 'yes' else ''}"
23PACKAGECONFIG:class-native ??= ""
24
25# Make readline and textstyle optional. There are recipie for these, but leave them
26# disabled for the native recipe. This prevents host contamination of the native tool.
27PACKAGECONFIG[readline] = "--with-libreadline-prefix,--without-libreadline-prefix,readline"
28PACKAGECONFIG[textstyle] = "--with-libtextstyle-prefix,--without-libtextstyle-prefix,gettext"
29
30# Include the cached configure variables, configure is really good at finding
31# libreadline, even if we don't want it.
32CACHED_CONFIGUREVARS += "${@bb.utils.contains('PACKAGECONFIG', 'readline', '', ' \
33 ac_cv_header_readline_history_h=no \
34 ac_cv_header_readline_readline_h=no \
35 gl_cv_lib_readline=no', d)}"
36
37# The automatic m4 path detection gets confused, so force the right value
38acpaths = "-I ./m4"
39
40do_compile:prepend() {
41 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
42}
43
44do_install:append:class-native() {
45 create_wrapper ${D}/${bindir}/bison \
46 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
47}
48do_install:append:class-nativesdk() {
49 create_wrapper ${D}/${bindir}/bison \
50 BISON_PKGDATADIR=${datadir}/bison
51}
52BBCLASSEXTEND = "native nativesdk"