summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.7.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.7.6.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.7.6.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.7.6.bb b/meta/recipes-devtools/bison/bison_3.7.6.bb
new file mode 100644
index 0000000000..a7f01c3299
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.7.6.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://add-with-bisonlocaledir.patch \
14 file://0001-Use-mapped-file-name-for-symbols.patch \
15 "
16SRC_URI[sha256sum] = "67d68ce1e22192050525643fc0a7a22297576682bef6a5c51446903f5aeef3cf"
17
18# No point in hardcoding path to m4, just use PATH
19EXTRA_OECONF += "M4=m4"
20
21inherit autotools gettext texinfo
22
23# The automatic m4 path detection gets confused, so force the right value
24acpaths = "-I ./m4"
25
26do_compile_prepend() {
27 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
28}
29
30do_install_append_class-native() {
31 create_wrapper ${D}/${bindir}/bison \
32 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
33}
34do_install_append_class-nativesdk() {
35 create_wrapper ${D}/${bindir}/bison \
36 BISON_PKGDATADIR=${datadir}/bison
37}
38BBCLASSEXTEND = "native nativesdk"