summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.7.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.7.5.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.7.5.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.7.5.bb b/meta/recipes-devtools/bison/bison_3.7.5.bb
new file mode 100644
index 0000000000..f8263f93a3
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.7.5.bb
@@ -0,0 +1,37 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://add-with-bisonlocaledir.patch \
14 "
15SRC_URI[sha256sum] = "e8c53bc5bc396d636622d0f25e31ca92fd53f00b09629f13ef540d564a6b31ab"
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
20inherit autotools gettext texinfo
21
22# The automatic m4 path detection gets confused, so force the right value
23acpaths = "-I ./m4"
24
25do_compile_prepend() {
26 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
27}
28
29do_install_append_class-native() {
30 create_wrapper ${D}/${bindir}/bison \
31 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
32}
33do_install_append_class-nativesdk() {
34 create_wrapper ${D}/${bindir}/bison \
35 BISON_PKGDATADIR=${datadir}/bison
36}
37BBCLASSEXTEND = "native nativesdk"