summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.5.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.5.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.5.bb b/meta/recipes-devtools/bison/bison_3.5.bb
new file mode 100644
index 0000000000..3d8f6579b9
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.5.bb
@@ -0,0 +1,40 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://dont-depend-on-help2man.patch.patch \
14 file://add-with-bisonlocaledir.patch \
15"
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
20SRC_URI[md5sum] = "c0230be066069f33c8445766833f3205"
21SRC_URI[sha256sum] = "55e4a023b1b4ad19095a5f8279f0dc048fa29f970759cea83224a6d5e7a3a641"
22
23inherit autotools gettext texinfo
24
25# The automatic m4 path detection gets confused, so force the right value
26acpaths = "-I ${S}/m4"
27
28do_compile_prepend() {
29 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
30}
31
32do_install_append_class-native() {
33 create_wrapper ${D}/${bindir}/bison \
34 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
35}
36do_install_append_class-nativesdk() {
37 create_wrapper ${D}/${bindir}/bison \
38 BISON_PKGDATADIR=${datadir}/bison
39}
40BBCLASSEXTEND = "native nativesdk"