summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.16.2.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.16.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.16.2.bb b/meta/recipes-devtools/automake/automake_1.16.2.bb
new file mode 100644
index 0000000000..fd8ed0ed3b
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.16.2.bb
@@ -0,0 +1,44 @@
1require automake.inc
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
20RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
21
22SRC_URI += "file://python-libdir.patch \
23 file://buildtest.patch \
24 file://performance.patch \
25 file://new_rt_path_for_test-driver.patch \
26 file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
27 file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
28 file://0001-build-fix-race-in-parallel-builds.patch \
29 "
30
31SRC_URI[md5sum] = "f1a14f2ab2b0fb861a011e1d94e589e0"
32SRC_URI[sha256sum] = "b2f361094b410b4acbf4efba7337bdb786335ca09eb2518635a09fb7319ca5c1"
33
34PERL = "${USRBINPATH}/perl"
35PERL_class-native = "${USRBINPATH}/env perl"
36PERL_class-nativesdk = "${USRBINPATH}/env perl"
37
38CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
39
40do_install_append () {
41 install -d ${D}${datadir}
42}
43
44BBCLASSEXTEND = "native nativesdk"