summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.12.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.12.3.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.12.3.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.12.3.bb b/meta/recipes-devtools/automake/automake_1.12.3.bb
new file mode 100644
index 0000000000..25069d72b5
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.12.3.bb
@@ -0,0 +1,62 @@
1require automake.inc
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_virtclass-native = "autoconf-native"
5
6RDEPENDS_${PN} += "\
7 autoconf \
8 perl \
9 perl-module-bytes \
10 perl-module-constant \
11 perl-module-cwd \
12 perl-module-data-dumper \
13 perl-module-dynaloader \
14 perl-module-errno \
15 perl-module-exporter-heavy \
16 perl-module-file-basename \
17 perl-module-file-compare \
18 perl-module-file-copy \
19 perl-module-file-glob \
20 perl-module-file-spec-unix \
21 perl-module-file-stat \
22 perl-module-getopt-long \
23 perl-module-io \
24 perl-module-io-file \
25 perl-module-posix \
26 perl-module-strict \
27 perl-module-text-parsewords \
28 perl-module-vars "
29
30RDEPENDS_${PN}_virtclass-native = "autoconf-native perl-native-runtime"
31RDEPENDS_${PN}_virtclass-nativesdk = "nativesdk-autoconf"
32
33PATHFIXPATCH = "file://path_prog_fixes.patch"
34PATHFIXPATCH_virtclass-native = ""
35PATHFIXPATCH_virtclass-nativesdk = ""
36
37SRC_URI += "${PATHFIXPATCH} \
38 file://prefer-cpio-over-pax-for-ustar-archives.patch \
39 file://python-libdir.patch \
40 file://py-compile-compile-only-optimized-byte-code.patch"
41
42SRC_URI[md5sum] = "d2af8484de94cdee16d89c50aaa1c729"
43SRC_URI[sha256sum] = "095ffaa3ac887d1eb3511bf13d7f1fc9ec0503c6a06aeae05c93730cdda9a5a0"
44
45PR = "r0"
46
47do_install () {
48 oe_runmake 'DESTDIR=${D}' install
49 install -d ${D}${datadir}
50
51 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
52 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
53 for i in aclocal aclocal-1.12 automake automake-1.12; do
54 if [ -f ${D}${bindir}/$i ]; then
55 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
56 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
57 ${D}${bindir}/$i
58 fi
59 done
60}
61
62BBCLASSEXTEND = "native nativesdk"