summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autoconf/autoconf_2.72e.bb')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf_2.72e.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf_2.72e.bb b/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
new file mode 100644
index 0000000000..db374373cf
--- /dev/null
+++ b/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
@@ -0,0 +1,83 @@
1SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
5LICENSE = "GPL-3.0-or-later"
6HOMEPAGE = "http://www.gnu.org/software/autoconf/"
7SECTION = "devel"
8DEPENDS = "m4-native autoconf-native automake-native gnu-config-native help2man-native"
9DEPENDS:remove:class-native = "autoconf-native automake-native help2man-native"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=cc3f3a7596cb558bbd9eb7fbaa3ef16c \
12 file://COPYINGv3;md5=1ebbd3e34237af26da5dc08a4e440464"
13
14SRC_URI = " \
15 https://alpha.gnu.org/gnu/autoconf/${BP}.tar.gz \
16 file://program_prefix.patch \
17 file://autoreconf-exclude.patch \
18 file://remove-usr-local-lib-from-m4.patch \
19 file://preferbash.patch \
20 file://autotest-automake-result-format.patch \
21 file://man-host-perl.patch \
22"
23SRC_URI:append:class-native = " file://no-man.patch"
24
25SRC_URI[sha256sum] = "f3478d3b597d51f5d61596fb2f6f6aba49cdd974b4b05ff0bac57f56b5cfdb39"
26
27RDEPENDS:${PN} = "m4 gnu-config \
28 perl \
29 perl-module-bytes \
30 perl-module-carp \
31 perl-module-constant \
32 perl-module-data-dumper \
33 perl-module-errno \
34 perl-module-exporter \
35 perl-module-file-basename \
36 perl-module-file-compare \
37 perl-module-file-copy \
38 perl-module-file-find \
39 perl-module-file-glob \
40 perl-module-file-path \
41 perl-module-file-spec \
42 perl-module-file-spec-unix \
43 perl-module-file-stat \
44 perl-module-file-temp \
45 perl-module-getopt-long \
46 perl-module-io-file \
47 perl-module-list-util \
48 perl-module-overloading \
49 perl-module-posix \
50 perl-module-scalar-util \
51 perl-module-symbol \
52 perl-module-thread-queue \
53 perl-module-threads \
54 perl-module-feature \
55 "
56RDEPENDS:${PN}:class-native = "m4-native gnu-config-native hostperl-runtime-native"
57
58inherit autotools texinfo
59
60PERL = "${USRBINPATH}/perl"
61PERL:class-native = "/usr/bin/env perl"
62PERL:class-nativesdk = "/usr/bin/env perl"
63
64CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
65
66EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
67
68# As autoconf installs its own config.* files, ensure that they're always up to date.
69update_gnu_config() {
70 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
71 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
72}
73do_configure[prefuncs] += "update_gnu_config"
74
75do_configure:class-native() {
76 oe_runconf
77}
78
79do_install:append() {
80 rm -rf ${D}${datadir}/emacs
81}
82
83BBCLASSEXTEND = "native nativesdk"