summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autoconf/autoconf_2.71.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autoconf/autoconf_2.71.bb')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf_2.71.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf_2.71.bb b/meta/recipes-devtools/autoconf/autoconf_2.71.bb
new file mode 100644
index 0000000000..3202a87273
--- /dev/null
+++ b/meta/recipes-devtools/autoconf/autoconf_2.71.bb
@@ -0,0 +1,78 @@
1SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
5LICENSE = "GPLv3+"
6HOMEPAGE = "http://www.gnu.org/software/autoconf/"
7SECTION = "devel"
8DEPENDS = "m4-native autoconf-native automake-native gnu-config-native help2man-native"
9DEPENDS_remove_class-native = "autoconf-native automake-native help2man-native"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=cc3f3a7596cb558bbd9eb7fbaa3ef16c \
12 file://COPYINGv3;md5=1ebbd3e34237af26da5dc08a4e440464"
13
14SRC_URI = "${GNU_MIRROR}/autoconf/${BP}.tar.gz \
15 file://program_prefix.patch \
16 file://autoreconf-exclude.patch \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://preferbash.patch \
19 file://autotest-automake-result-format.patch \
20 file://man-host-perl.patch \
21 "
22SRC_URI_append_class-native = " file://no-man.patch"
23
24SRC_URI[sha256sum] = "431075ad0bf529ef13cb41e9042c542381103e80015686222b8a9d4abef42a1c"
25
26RDEPENDS_${PN} = "m4 gnu-config \
27 perl \
28 perl-module-bytes \
29 perl-module-carp \
30 perl-module-constant \
31 perl-module-data-dumper \
32 perl-module-errno \
33 perl-module-exporter \
34 perl-module-file-basename \
35 perl-module-file-compare \
36 perl-module-file-copy \
37 perl-module-file-find \
38 perl-module-file-glob \
39 perl-module-file-path \
40 perl-module-file-spec \
41 perl-module-file-spec-unix \
42 perl-module-file-stat \
43 perl-module-getopt-long \
44 perl-module-io-file \
45 perl-module-overloading \
46 perl-module-posix \
47 perl-module-symbol \
48 perl-module-thread-queue \
49 perl-module-threads \
50 "
51RDEPENDS_${PN}_class-native = "m4-native gnu-config-native hostperl-runtime-native"
52
53inherit autotools texinfo
54
55PERL = "${USRBINPATH}/perl"
56PERL_class-native = "/usr/bin/env perl"
57PERL_class-nativesdk = "/usr/bin/env perl"
58
59CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
60
61EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
62
63# As autoconf installs its own config.* files, ensure that they're always up to date.
64update_gnu_config() {
65 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
66 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
67}
68do_configure[prefuncss] += "update_gnu_config"
69
70do_configure_class-native() {
71 oe_runconf
72}
73
74do_install_append() {
75 rm -rf ${D}${datadir}/emacs
76}
77
78BBCLASSEXTEND = "native nativesdk"