summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.2.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.2.24.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.24.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.2.24.bb b/meta/recipes-devtools/apt/apt_1.2.24.bb
new file mode 100644
index 0000000000..ae0bce933d
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_1.2.24.bb
@@ -0,0 +1,20 @@
1DEPENDS = "curl db zlib"
2RDEPENDS_${PN} = "dpkg bash debianutils"
3require apt.inc
4
5require apt-package.inc
6
7PACKAGECONFIG ??= "lzma"
8PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
9PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
10PACKAGECONFIG[lz4] = "ac_cv_lib_lz4_LZ4F_createCompressionContext=yes,ac_cv_lib_lz4_LZ4F_createCompressionContext=no,lz4"
11
12FILES_${PN} += "${bindir}/apt-key"
13apt-manpages += "doc/apt-key.8"
14
15do_install_append() {
16 #Write the correct apt-architecture to apt.conf
17 APT_CONF=${D}/etc/apt/apt.conf
18 echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
19 oe_libinstall -so -C bin libapt-private ${D}${libdir}/
20}