summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.39.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.39.3.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.39.3.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.39.3.bb b/meta/recipes-core/util-linux/util-linux_2.39.3.bb
index 83b3f4e05b..2cd7750afc 100644
--- a/meta/recipes-core/util-linux/util-linux_2.39.3.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.39.3.bb
@@ -148,7 +148,7 @@ SYSTEMD_SERVICE:${PN}-fstrim = "fstrim.timer fstrim.service"
148SYSTEMD_AUTO_ENABLE:${PN}-fstrim = "disable" 148SYSTEMD_AUTO_ENABLE:${PN}-fstrim = "disable"
149 149
150do_compile:append () { 150do_compile:append () {
151 cp ${WORKDIR}/fcntl-lock.c ${S}/fcntl-lock.c 151 cp ${UNPACKDIR}/fcntl-lock.c ${S}/fcntl-lock.c
152 ${CC} ${CFLAGS} ${LDFLAGS} ${S}/fcntl-lock.c -o ${B}/fcntl-lock 152 ${CC} ${CFLAGS} ${LDFLAGS} ${S}/fcntl-lock.c -o ${B}/fcntl-lock
153} 153}
154 154
@@ -194,8 +194,8 @@ do_install () {
194do_install:append:class-target () { 194do_install:append:class-target () {
195 if [ "${@bb.utils.filter('PACKAGECONFIG', 'pam', d)}" ]; then 195 if [ "${@bb.utils.filter('PACKAGECONFIG', 'pam', d)}" ]; then
196 install -d ${D}${sysconfdir}/pam.d 196 install -d ${D}${sysconfdir}/pam.d
197 install -m 0644 ${WORKDIR}/runuser.pamd ${D}${sysconfdir}/pam.d/runuser 197 install -m 0644 ${UNPACKDIR}/runuser.pamd ${D}${sysconfdir}/pam.d/runuser
198 install -m 0644 ${WORKDIR}/runuser-l.pamd ${D}${sysconfdir}/pam.d/runuser-l 198 install -m 0644 ${UNPACKDIR}/runuser-l.pamd ${D}${sysconfdir}/pam.d/runuser-l
199 # Required for "su -" aka "su --login" because 199 # Required for "su -" aka "su --login" because
200 # otherwise it uses "other", which has "auth pam_deny.so" 200 # otherwise it uses "other", which has "auth pam_deny.so"
201 # and thus prevents the operation. 201 # and thus prevents the operation.
@@ -282,8 +282,11 @@ blkid.8 eject.1 findfs.8 fsck.8 kill.1 last.1 lastb.1 libblkid.3 logger.1 mesg.1
282mountpoint.1 nologin.8 rfkill.8 sulogin.8 utmpdump.1 uuid.3 wall.1\ 282mountpoint.1 nologin.8 rfkill.8 sulogin.8 utmpdump.1 uuid.3 wall.1\
283" 283"
284ALTERNATIVE:${PN}-doc += "${@bb.utils.contains('PACKAGECONFIG', 'pam', 'su.1', '', d)}" 284ALTERNATIVE:${PN}-doc += "${@bb.utils.contains('PACKAGECONFIG', 'pam', 'su.1', '', d)}"
285ALTERNATIVE:${PN}-doc += "${@bb.utils.contains('PACKAGECONFIG', 'chfn-chsh', 'chfn.1 chsh.1', '', d)}"
285 286
286ALTERNATIVE_LINK_NAME[blkid.8] = "${mandir}/man8/blkid.8" 287ALTERNATIVE_LINK_NAME[blkid.8] = "${mandir}/man8/blkid.8"
288ALTERNATIVE_LINK_NAME[chfn.1] = "${mandir}/man1/chfn.1"
289ALTERNATIVE_LINK_NAME[chsh.1] = "${mandir}/man1/chsh.1"
287ALTERNATIVE_LINK_NAME[eject.1] = "${mandir}/man1/eject.1" 290ALTERNATIVE_LINK_NAME[eject.1] = "${mandir}/man1/eject.1"
288ALTERNATIVE_LINK_NAME[findfs.8] = "${mandir}/man8/findfs.8" 291ALTERNATIVE_LINK_NAME[findfs.8] = "${mandir}/man8/findfs.8"
289ALTERNATIVE_LINK_NAME[fsck.8] = "${mandir}/man8/fsck.8" 292ALTERNATIVE_LINK_NAME[fsck.8] = "${mandir}/man8/fsck.8"
@@ -319,7 +322,7 @@ do_install_ptest() {
319 cp ${S}/tests/*.sh ${D}${PTEST_PATH}/tests/ 322 cp ${S}/tests/*.sh ${D}${PTEST_PATH}/tests/
320 cp -pR ${S}/tests/expected ${D}${PTEST_PATH}/tests/expected 323 cp -pR ${S}/tests/expected ${D}${PTEST_PATH}/tests/expected
321 cp -pR ${S}/tests/ts ${D}${PTEST_PATH}/tests/ 324 cp -pR ${S}/tests/ts ${D}${PTEST_PATH}/tests/
322 cp ${WORKDIR}/build/config.h ${D}${PTEST_PATH} 325 cp ${B}/config.h ${D}${PTEST_PATH}
323 326
324 sed -i 's|@base_sbindir@|${base_sbindir}|g' ${D}${PTEST_PATH}/run-ptest 327 sed -i 's|@base_sbindir@|${base_sbindir}|g' ${D}${PTEST_PATH}/run-ptest
325 328