summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ttyrun/ttyrun_2.32.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ttyrun/ttyrun_2.32.0.bb')
-rw-r--r--meta/recipes-core/ttyrun/ttyrun_2.32.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/ttyrun/ttyrun_2.32.0.bb b/meta/recipes-core/ttyrun/ttyrun_2.32.0.bb
new file mode 100644
index 0000000000..815f625a67
--- /dev/null
+++ b/meta/recipes-core/ttyrun/ttyrun_2.32.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Start the program if the specified terminal device is available."
2DESCRIPTION = "ttyrun is typically used to prevent a respawn through the \
3init(8) program when a terminal is not available."
4HOMEPAGE = "https://github.com/ibm-s390-linux/s390-tools"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=f5118f167b055bfd7c3450803f1847af"
8
9SRC_URI = "git://github.com/ibm-s390-linux/s390-tools;protocol=https;branch=master"
10SRCREV = "9eea78b3ad8ab3710fb3b2d80b9cd058d7c8aba7"
11
12CVE_PRODUCT = "s390-tools"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = "\
17 V=1 \
18 CC="${CC}" \
19 DISTRELEASE=${PR} \
20 "
21
22# We just want ttyrun and not the rest of s390-utils
23
24do_configure() {
25 oe_runmake -C ${S}/iucvterm/src clean
26}
27
28do_compile() {
29 oe_runmake -C ${S}/iucvterm/src ttyrun
30}
31
32do_install() {
33 install -d ${D}${sbindir}
34 install ${S}/iucvterm/src/ttyrun ${D}${sbindir}
35}